Bitswap

CME with SIP and SKINNY phones

Posted by Andy on March 25, 2009

  • 7960 firmware P0S3-07-5-00 does NOT work with cme 7.0(1) (Phone doesn’t recognize “USECALLMANAGER” item in SIPDefault.cn
  • 7960 firmware P0S3-08-6-00 does work with cme 7.0(1)
  • CME & SIP implementation guide 


Current configuration : 4921 bytes
!
! Last configuration change at 02:55:50 UTC Wed Mar 25 2009
! NVRAM config last updated at 01:48:01 UTC Wed Mar 25 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname BR2
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/3
logging message-counter syslog
!
no aaa new-model
clock calendar-valid
!
dot11 syslog
ip source-route
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice dsp waitstate 0
!
voice service voip
allow-connections sip to sip
sip
registrar server expires max 1200 min 300
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 172.30.2.3 port 5060
max-dn 10
max-pool 10
load 7960-7940 P0S3-08-6-00
authenticate register
authenticate realm cisco.com
tftp-path flash:
file text
create profile sync 0006283557111171
!
voice register dn 6
number 2005
allow watch
name 2005
label 2005
!
voice register pool 6
id mac 0003.E3C4.4FE7
type 7960
number 1 dn 6
dtmf-relay sip-notify
username phone6 password cisco
codec g711ulaw
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 172.30.2.3 255.255.255.0
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.30.2.1
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
tftp-server flash:phone/7940-60/P00308000600.bin alias P00308000600.bin
tftp-server flash:phone/7940-60/P00308000600.loads alias P00308000600.loads
tftp-server flash:phone/7940-60/P00308000600.sb2 alias P00308000600.sb2
tftp-server flash:phone/7940-60/P00308000600.sbn alias P00308000600.sbn
tftp-server flash:phone/7940-60/OS79XX.txt alias OS79XX.txt
tftp-server flash:phone/7940-60/P003-08-6-00.bin alias P003-08-6-00.bin
tftp-server flash:phone/7940-60/P003-08-6-00.sbn alias P003-08-6-00.sbn
tftp-server flash:phone/7940-60/P0S3-08-6-00.loads alias P0S3-08-6-00.loads
tftp-server flash:phone/7940-60/P0S3-08-6-00.sb2 alias P0S3-08-6-00.sb2
tftp-server flash:phone/7940-60/P0S3-07-5-00.bin alias P0S3-07-5-00.bin
tftp-server flash:phone/7940-60/P0S3-07-5-00.loads alias P0S3-07-5-00.loads
tftp-server flash:phone/7940-60/P0S3-07-5-00.sb2 alias P0S3-07-5-00.sb2
tftp-server flash:phone/7940-60/P003-07-5-00.bin alias P003-07-5-00.bin
tftp-server flash:phone/7940-60/P003-07-5-00.sbn alias P003-07-5-00.sbn
!
control-plane
!
!
!
voice-port 0/2/0
!
voice-port 0/2/1
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
telephony-service
em logout 0:0 0:0 0:0
max-ephones 100
max-dn 100
ip source-address 172.30.2.3 port 2000
max-conferences 8 gain -6
transfer-system full-consult
server-security-mode non-secure
create cnf-files version-stamp 7960 Mar 25 2009 00:50:39
!
!
ephone-dn 1 dual-line
number 2000
!
!
ephone-dn 2 dual-line
number 2001
!
!
ephone-dn 3 dual-line
number 2002
!
!
ephone-dn 4 dual-line
number 2003
!
!
ephone-dn 5 dual-line
number 2004
!
!
ephone-dn 7 dual-line
number 2006
!
!
ephone-dn 8 dual-line
number 2007
!
!
ephone 1
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 001A.2FF5.9E1D
type 7940
button 1:1
!
!
!
ephone 2
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 0015.6389.B343
type 7960
button 1:2
!
!
!
ephone 3
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 0019.AAAC.DF8A
type 7940
button 1:3
!
!
!
ephone 4
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 001D.4543.8DCD
type 7961
button 1:4
!
!
!
ephone 5
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 0014.A981.8A9B
type 7960
button 1:5
!
!
!
ephone 6
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 02EA.EAEA.0006
type 7960
!
!
!
ephone 7
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
mac-address 001C.58A3.1831
type 7941
button 1:5
!
!
!
ephone 8
no phone-ui speeddial-fastdial
no multicast-moh
device-security-mode none
!
!
!
line con 0
privilege level 15
line aux 0
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
line vty 5
privilege level 15
logging synchronous
no login
line vty 6 15
privilege level 15
no login
!
scheduler allocate 20000 1000
ntp server 10.129.1.1
sntp server 10.129.1.1
end

Booting of SIP phone.

Mar 25 02:57:12.866: TFTP: Looking for SIPDefault.cnf
Mar 25 02:57:12.866: TFTP: Opened flash:/SIPDefault.cnf, fd 7, size 1889 for process 229
Mar 25 02:57:12.878: TFTP: Finished flash:/SIPDefault.cnf, time 00:00:00 for process 229
Mar 25 02:57:13.042: TFTP: Looking for SIP0003E3C44FE7.cnf
Mar 25 02:57:13.042: TFTP: Opened flash:/SIP0003E3C44FE7.cnf, fd 7, size 1230 for process 229
Mar 25 02:57:13.054: TFTP: Finished flash:/SIP0003E3C44FE7.cnf, time 00:00:00 for process 229
BR2#
Mar 25 02:57:15.050: VOICE_REG_POOL: Register request for (2005) from (172.30.2.100)
Mar 25 02:57:15.050: VOICE_REG_POOL: key(A2B3A5C6000B0C61) added to nonce table
Mar 25 02:57:15.050: VOICE_REG_POOL: Contact doesn’t match any pools
Mar 25 02:57:15.222: VOICE_REG_POOL: Register request for (2005) from (172.30.2.100)
Mar 25 02:57:15.222: VOICE_REG_POOL: Contact matches pool 6 number list 1
Mar 25 02:57:15.222: VOICE_REG_POOL: key(2005) contact(172.30.2.100) add to contact table
Mar 25 02:57:15.222: VOICE_REG_POOL: No entry for (2005) found in contact table
Mar 25 02:57:15.226: VOICE_REG_POOL: key(2005) contact(172.30.2.100) added to contact table
BR2#
Mar 25 02:57:15.226: VOICE_REG_POOL pool->tag(6), dn->tag(6), submask(1)

Mar 25 02:57:15.226: VOICE_REG_POOL: Creating param container for dial-peer 40001.VOICE_REG_POOL pool->tag(6), dn->tag(6), submask(1)

Mar 25 02:57:15.226: VOICE_REG_POOL: Created dial-peer entry of type 0
Mar 25 02:57:15.226: VOICE_REG_POOL: Registration successful for 2005, registration id is 1
Mar 25 02:57:15.230: VOICE REGISTER POOL-6 has registered. Name:SEP0003E3C44FE7 IP:172.30.2.100 DeviceType:Phone

Mar 25 02:57:15.230: VOICE_REG_POOL: Pool[6]: service-control (reset type: 2) message sent to sip:2005@172.30.2.100

Mar 25 02:57:15.666: TFTP: Looking for RINGLIST.DAT
BR2#
Mar 25 02:57:46.478: ephone-2[1/4]:MediaPathEventMessage
BR2#
Mar 25 02:57:55.170: ephone-2[1/4]:MediaPathEventMessage

Advertisements

One Response to “CME with SIP and SKINNY phones”

  1. Andy said

    When you going to upgrade 7941/7961 from SCCP to SIP remember what to include two lines into voice register global:

    load 7961 term61.default
    load 7941 term41.default

    for 7940/60 only one :

    load 7960-7940 P0S3-08-6-00

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: